restaurant pos performance issue
Incident Report for SpotOn Services
Resolved
This incident has been resolved.
Posted Sep 03, 2022 - 01:53 UTC
Investigating
We are investigating reports of slowness in the Restaurant POS.
Posted Sep 03, 2022 - 01:37 UTC
This incident affected: SpotOn Restaurant.