Teamwork Wages Disription

Incident Report for SpotOn Services

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 18:17 UTC

Monitoring

A fix has been implemented and we're monitoring the results.
Posted Jul 03, 2026 - 17:35 UTC

Update

The fix is running and locations are starting to be restored to regular wage data.
Posted Jul 03, 2026 - 16:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 03, 2026 - 16:05 UTC

Investigating

We are investigating issues related to wages set in our Teamwork product and will provide updates.
Posted Jul 03, 2026 - 15:42 UTC
This incident affected: Additional Products (Teamwork).