Support Phone Lines are down - please use email

Incident Report for SpotOn Services

Resolved

This issue has been resolved and you can resume using the support lines. Thank you for your patience!
Posted Sep 06, 2025 - 00:26 UTC

Monitoring

Our phone lines are beginning to recover as our telecom provider is coming back in service. If you are still unable to reach support via phone, please use our email support@spoton.com. Will provide update when we are fully resolved.
Posted Sep 05, 2025 - 21:01 UTC

Investigating

We are experiencing an outage with our Telecom provider and unable to provide phone support. Please email support@spoton.com for any inquiries/issues or access our live chat on spoton.com. Our teams are working on a resolution. Please check our status page for updates
Posted Sep 05, 2025 - 19:47 UTC
This incident affected: Support (Support Phone).