TSYS Credit card processing issues
Incident Report for SpotOn Services
Resolved
This incident has been resolved.
Posted Feb 25, 2022 - 15:15 UTC
Monitoring
We’re seeing a return to normal processing with TSYS. We are monitoring the situation.
Posted Feb 25, 2022 - 15:02 UTC
Update
TSYS, a credit card processor for SpotOn and many other POS companies, is experiencing system issues, which may have affected your ability to run card transactions on your SpotOn point-of-sale.
Posted Feb 25, 2022 - 13:57 UTC
Update
We are continuing to investigate this issue.
Posted Feb 25, 2022 - 13:56 UTC
Update
TSYS, a credit card processor for SpotOn and many other POS companies, is experiencing system issues, which may have affected your ability to run card transactions on your SpotOn point-of-sale.
Posted Feb 25, 2022 - 13:53 UTC
Investigating
Teams are investigating a possible incident on Restaurants
Posted Feb 25, 2022 - 13:25 UTC
This incident affected: SpotOn Restaurant and Payment Processing.