Teamwork Application Outage

Incident Report for SpotOn Services

Resolved

This incident has been resolved.
Posted May 11, 2025 - 22:02 UTC

Investigating

We are currently investigating an issue affecting Teamwork. Customers may experience screens and data not loading in the application. Our team is working to identify the root cause.
Posted May 11, 2025 - 20:36 UTC
This incident affected: Additional Products (Teamwork).