Funding Delay for Some Merchants

Incident Report for SpotOn Services

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 21:44 UTC

Monitoring

Today's funding is running behind schedule for some merchants. You can expect to receive your funds as follows:

• If using Morning Funding: 3–4 hours later than your usual funding time
• If using traditional ACH funding: by approximately 5:00 p.m. local time

We apologize for the inconvenience and appreciate your patience. Funds are on their way and no action is needed on your end.
Posted Jun 10, 2026 - 16:29 UTC
This incident affected: Payments (Deposits (Worldpay)).